import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^/pictures/(([a-z0-9]{2,2})([a-z0-9]{2,2})[a-z0-9]{28}\\.\\w+)";
final String string = "/pictures/202cb962ac59075b964b07152d234b70.jpg";
final String subst = "/p/$2/$3/$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}