const regex = new RegExp('^/pictures/(([a-z0-9]{2,2})([a-z0-9]{2,2})[a-z0-9]{28}\\.\\w+)', 'gmi')
const str = `/pictures/202cb962ac59075b964b07152d234b70.jpg`;
const subst = `/p/$2/$3/$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);