package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^/pictures/(([a-z0-9]{2,2})([a-z0-9]{2,2})[a-z0-9]{28}\.\w+)`)
var str = `/pictures/202cb962ac59075b964b07152d234b70.jpg`
var substitution = "/p/$2/$3/$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}