// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^/pictures/(([a-z0-9]{2,2})([a-z0-9]{2,2})[a-z0-9]{28}\.\w+)").unwrap();
let string = "/pictures/202cb962ac59075b964b07152d234b70.jpg";
let substitution = "/p/$2/$3/$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}