re = /^\/pictures\/(([a-z0-9]{2,2})([a-z0-9]{2,2})[a-z0-9]{28}\.\w+)/mi
str = '/pictures/202cb962ac59075b964b07152d234b70.jpg'
subst = '/p/$2/$3/$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result