use strict;
my $str = 'I <strong>really</strong> want to get rid of the strong-tags!
<a
href="./here.html">Text</a>';
my $regex = qr/<[^<>]*>/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";