#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[+\.\w\+-]*@[\w-]+(\.[a-z]{2,6})*(\.[a-z]{2,6})$"
Local $sString = "martina-steinbacher@gmx.net" & @CRLF & _
"hello@example.com" & @CRLF & _
"hello@example.co.uk" & @CRLF & _
"hello-2020@example.com" & @CRLF & _
"hello.2020@example.com" & @CRLF & _
"hello_2020@example.com" & @CRLF & _
"h@example.com" & @CRLF & _
"h@example-example.com" & @CRLF & _
"h@example-example-example.com" & @CRLF & _
"hello@-example.com" & @CRLF & _
"hello@example_example.com" & @CRLF & _
"hello.world-2020@example.com" & @CRLF & _
"1234567890123456789012345678901234567890123456789012345678901234xx@example.com" & @CRLF & _
"ewfefewf+dsv.sdvsdv@example.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")