// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[+\.\w\+-]*@[\w-]+(\.[a-z]{2,6})*(\.[a-z]{2,6})$").unwrap();
let string = "martina-steinbacher@gmx.net
hello@example.com
hello@example.co.uk
hello-2020@example.com
hello.2020@example.com
hello_2020@example.com
h@example.com
h@example-example.com
h@example-example-example.com
hello@-example.com
hello@example_example.com
hello.world-2020@example.com
1234567890123456789012345678901234567890123456789012345678901234xx@example.com
ewfefewf+dsv.sdvsdv@example.com";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}