import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[+\\.\\w\\+-]*@[\\w-]+(\\.[a-z]{2,6})*(\\.[a-z]{2,6})$";
final String string = "martina-steinbacher@gmx.net\n"
+ "hello@example.com\n"
+ "hello@example.co.uk\n"
+ "hello-2020@example.com\n"
+ "hello.2020@example.com\n"
+ "hello_2020@example.com\n"
+ "h@example.com\n"
+ "h@example-example.com\n"
+ "h@example-example-example.com\n"
+ "hello@-example.com\n"
+ "hello@example_example.com\n"
+ "hello.world-2020@example.com\n"
+ "1234567890123456789012345678901234567890123456789012345678901234xx@example.com\n"
+ "ewfefewf+dsv.sdvsdv@example.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}