import re
regex = re.compile(r"^[+\.\w\+-]*@[\w-]+(\.[a-z]{2,6})*(\.[a-z]{2,6})$", flags=re.MULTILINE)
test_str = ("martina-steinbacher@gmx.net\n"
"hello@example.com\n"
"hello@example.co.uk\n"
"hello-2020@example.com\n"
"hello.2020@example.com\n"
"hello_2020@example.com\n"
"h@example.com\n"
"h@example-example.com\n"
"h@example-example-example.com\n"
"hello@-example.com\n"
"hello@example_example.com\n"
"hello.world-2020@example.com\n"
"1234567890123456789012345678901234567890123456789012345678901234xx@example.com\n"
"ewfefewf+dsv.sdvsdv@example.com")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")