using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[+\.\w\+-]*@[\w-]+(\.[a-z]{2,6})*(\.[a-z]{2,6})$";
string input = @"martina-steinbacher@gmx.net
hello@example.com
hello@example.co.uk
hello-2020@example.com
hello.2020@example.com
hello_2020@example.com
h@example.com
h@example-example.com
h@example-example-example.com
hello@-example.com
hello@example_example.com
hello.world-2020@example.com
1234567890123456789012345678901234567890123456789012345678901234xx@example.com
ewfefewf+dsv.sdvsdv@example.com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}