const regex = /^[+\.\w\+-]*@[\w-]+(\.[a-z]{2,6})*(\.[a-z]{2,6})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[+\\.\\w\\+-]*@[\\w-]+(\\.[a-z]{2,6})*(\\.[a-z]{2,6})$', 'gm')
const str = `martina-steinbacher@gmx.net
hello@example.com
hello@example.co.uk
hello-2020@example.com
hello.2020@example.com
hello_2020@example.com
h@example.com
h@example-example.com
h@example-example-example.com
hello@-example.com
hello@example_example.com
hello.world-2020@example.com
1234567890123456789012345678901234567890123456789012345678901234xx@example.com
ewfefewf+dsv.sdvsdv@example.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}