use strict;
my $str = 'martina-steinbacher@gmx.net
hello@example.com
hello@example.co.uk
hello-2020@example.com
hello.2020@example.com
hello_2020@example.com
h@example.com
h@example-example.com
h@example-example-example.com
hello@-example.com
hello@example_example.com
hello.world-2020@example.com
1234567890123456789012345678901234567890123456789012345678901234xx@example.com
ewfefewf+dsv.sdvsdv@example.com';
my $regex = qr/^[+\.\w\+-]*@[\w-]+(\.[a-z]{2,6})*(\.[a-z]{2,6})$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}