package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[+\.\w\+-]*@[\w-]+(\.[a-z]{2,6})*(\.[a-z]{2,6})$`)
var str = `martina-steinbacher@gmx.net
hello@example.com
hello@example.co.uk
hello-2020@example.com
hello.2020@example.com
hello_2020@example.com
h@example.com
h@example-example.com
h@example-example-example.com
hello@-example.com
hello@example_example.com
hello.world-2020@example.com
1234567890123456789012345678901234567890123456789012345678901234xx@example.com
ewfefewf+dsv.sdvsdv@example.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}