#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\/\/([^\"]+?)$"
Local $sString = "// coment1" & @CRLF & _
""//coment"" & @CRLF & _
"//coment2" & @CRLF & _
"" & @CRLF & _
"console.log("//coment"); //coment3" & @CRLF & _
"myfunc("//coment");" & @CRLF & _
"//coment 1232dfs s d" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"somefunc1("//coment");" & @CRLF & _
"somefunc2("//coment");" & @CRLF & _
"" & @CRLF & _
"//end comment" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")