$re = '/\/\/([^\"]+?)$/m';
$str = '// coment1
"//coment"
//coment2
console.log("//coment"); //coment3
myfunc("//coment");
//coment 1232dfs s d
somefunc1("//coment");
somefunc2("//coment");
//end comment
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);