package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\/\/([^\"]+?)$`)
var str = `// coment1
"//coment"
//coment2
console.log("//coment"); //coment3
myfunc("//coment");
//coment 1232dfs s d
somefunc1("//coment");
somefunc2("//coment");
//end comment
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}