// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)\/\/([^\"]+?)$"#).unwrap();
let string = "// coment1
\"//coment\"
//coment2
console.log(\"//coment\"); //coment3
myfunc(\"//coment\");
//coment 1232dfs s d
somefunc1(\"//coment\");
somefunc2(\"//coment\");
//end comment
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}