re = /\/\/([^\"]+?)$/m
str = '// coment1
"//coment"
//coment2
console.log("//coment"); //coment3
myfunc("//coment");
//coment 1232dfs s d
somefunc1("//coment");
somefunc2("//coment");
//end comment
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end