import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/\\/([^\\\"]+?)$";
final String string = "// coment1\n"
+ "\"//coment\"\n"
+ "//coment2\n\n"
+ "console.log(\"//coment\"); //coment3\n"
+ "myfunc(\"//coment\");\n"
+ "//coment 1232dfs s d\n\n\n"
+ "somefunc1(\"//coment\");\n"
+ "somefunc2(\"//coment\");\n\n"
+ "//end comment\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}