using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/\/([^\""]+?)$";
string input = @"// coment1
""//coment""
//coment2
console.log(""//coment""); //coment3
myfunc(""//coment"");
//coment 1232dfs s d
somefunc1(""//coment"");
somefunc2(""//coment"");
//end comment
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}