using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*\/polygon\/all\/[0-9]*\.?[0-9]+\/[0-9]*\.?[0-9]+";
string input = @"http://gondor.ts.cynn.io:8087/polygon/all/55.23234/33.1983179237";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}