import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*\\/polygon\\/all\\/[0-9]*\\.?[0-9]+\\/[0-9]*\\.?[0-9]+";
final String string = "http://gondor.ts.cynn.io:8087/polygon/all/55.23234/33.1983179237";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}