use strict;
my $str = 'http://gondor.ts.cynn.io:8087/polygon/all/55.23234/33.1983179237';
my $regex = qr/.*\/polygon\/all\/[0-9]*\.?[0-9]+\/[0-9]*\.?[0-9]+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}