import re
regex = re.compile(r".*\/polygon\/all\/[0-9]*\.?[0-9]+\/[0-9]*\.?[0-9]+", flags=re.MULTILINE)
test_str = "http://gondor.ts.cynn.io:8087/polygon/all/55.23234/33.1983179237"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")