$re = '/.*\/polygon\/all\/[0-9]*\.?[0-9]+\/[0-9]*\.?[0-9]+/m';
$str = 'http://gondor.ts.cynn.io:8087/polygon/all/55.23234/33.1983179237';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);