#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)Field<([a-zA-Z]+)>\("([a-zA-Z]+)", null, nullable: true, null\);"
Local $sString = "Field<OrderByEnumType>("id", null, nullable: true, null);" & @CRLF & _
"Field<OrderType>("from_id", null, nullable: true, null);" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = "Field(x => x.$2, nullable: true, type: typeof($1));"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)