using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Field<([a-zA-Z]+)>\(""([a-zA-Z]+)"", null, nullable: true, null\);";
string substitution = @"Field(x => x.$2, nullable: true, type: typeof($1));";
string input = @"Field<OrderByEnumType>(""id"", null, nullable: true, null);
Field<OrderType>(""from_id"", null, nullable: true, null);
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}