$re = '/Field<([a-zA-Z]+)>\("([a-zA-Z]+)", null, nullable: true, null\);/m';
$str = 'Field<OrderByEnumType>("id", null, nullable: true, null);
Field<OrderType>("from_id", null, nullable: true, null);
';
$subst = "Field(x => x.$2, nullable: true, type: typeof($1));";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;