#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[abce-zABCE-Z][a-z]|[a-zA-Z][a-df-z]).*"
Local $sString = "de" & @CRLF & _
"DE" & @CRLF & _
"dE" & @CRLF & _
"De" & @CRLF & _
"" & @CRLF & _
"des" & @CRLF & _
"DES" & @CRLF & _
"dES" & @CRLF & _
"Des" & @CRLF & _
"test" & @CRLF & _
"deSomething" & @CRLF & _
"diSomething"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")