$re = '/^(?:[abce-zABCE-Z][a-z]|[a-zA-Z][a-df-z]).*/m';
$str = 'de
DE
dE
De
des
DES
dES
Des
test
deSomething
diSomething';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);