re = /^(?:[abce-zABCE-Z][a-z]|[a-zA-Z][a-df-z]).*/m
str = 'de
DE
dE
De
des
DES
dES
Des
test
deSomething
diSomething'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end