package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[abce-zABCE-Z][a-z]|[a-zA-Z][a-df-z]).*`)
var str = `de
DE
dE
De
des
DES
dES
Des
test
deSomething
diSomething`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}