// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:[abce-zABCE-Z][a-z]|[a-zA-Z][a-df-z]).*").unwrap();
let string = "de
DE
dE
De
des
DES
dES
Des
test
deSomething
diSomething";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}