import re
regex = re.compile(r"^(?:[abce-zABCE-Z][a-z]|[a-zA-Z][a-df-z]).*", flags=re.MULTILINE)
test_str = ("de\n"
"DE\n"
"dE\n"
"De\n\n"
"des\n"
"DES\n"
"dES\n"
"Des\n"
"test\n"
"deSomething\n"
"diSomething")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")