import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[abce-zABCE-Z][a-z]|[a-zA-Z][a-df-z]).*";
final String string = "de\n"
+ "DE\n"
+ "dE\n"
+ "De\n\n"
+ "des\n"
+ "DES\n"
+ "dES\n"
+ "Des\n"
+ "test\n"
+ "deSomething\n"
+ "diSomething";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}