using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[abce-zABCE-Z][a-z]|[a-zA-Z][a-df-z]).*";
string input = @"de
DE
dE
De
des
DES
dES
Des
test
deSomething
diSomething";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}