#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\w+)@.+\.(fr|com)\b"
Local $sString = "+coordonnées" & @CRLF & _
"10/12, rue du Ballon" & @CRLF & _
"Z.I. Richardets" & @CRLF & _
"93165 NOISY-LE-GRAND" & @CRLF & _
" " & @CRLF & _
"Tél. +33 (0)1 43 05 07 00" & @CRLF & _
"Fax +33 (0)1 43 05 45 28 agsm@agsm.fr"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")