using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w+)@.+\.(fr|com)\b";
string input = @"+coordonnées
10/12, rue du Ballon
Z.I. Richardets
93165 NOISY-LE-GRAND
Tél. +33 (0)1 43 05 07 00
Fax +33 (0)1 43 05 45 28 agsm@agsm.fr";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}