$re = '/(\w+)@.+\.(fr|com)\b/';
$str = '+coordonnées
10/12, rue du Ballon
Z.I. Richardets
93165 NOISY-LE-GRAND
Tél. +33 (0)1 43 05 07 00
Fax +33 (0)1 43 05 45 28 agsm@agsm.fr';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);