re = /(\w+)@.+\.(fr|com)\b/
str = '+coordonnées
10/12, rue du Ballon
Z.I. Richardets
93165 NOISY-LE-GRAND
Tél. +33 (0)1 43 05 07 00
Fax +33 (0)1 43 05 45 28 agsm@agsm.fr'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end