use strict;
my $str = '+coordonnées
10/12, rue du Ballon
Z.I. Richardets
93165 NOISY-LE-GRAND
Tél. +33 (0)1 43 05 07 00
Fax +33 (0)1 43 05 45 28 agsm@agsm.fr';
my $regex = qr/(\w+)@.+\.(fr|com)\b/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}