import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w+)@.+\\.(fr|com)\\b";
final String string = "+coordonnées\n"
+ "10/12, rue du Ballon\n"
+ "Z.I. Richardets\n"
+ "93165 NOISY-LE-GRAND\n"
+ " \n"
+ "Tél. +33 (0)1 43 05 07 00\n"
+ "Fax +33 (0)1 43 05 45 28 agsm@agsm.fr";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}