// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\w+)@.+\.(fr|com)\b").unwrap();
let string = "+coordonnées
10/12, rue du Ballon
Z.I. Richardets
93165 NOISY-LE-GRAND
Tél. +33 (0)1 43 05 07 00
Fax +33 (0)1 43 05 45 28 agsm@agsm.fr";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}