import re
regex = re.compile(r"(\w+)@.+\.(fr|com)\b")
test_str = ("+coordonnées\n"
"10/12, rue du Ballon\n"
"Z.I. Richardets\n"
"93165 NOISY-LE-GRAND\n"
" \n"
"Tél. +33 (0)1 43 05 07 00\n"
"Fax +33 (0)1 43 05 45 28 agsm@agsm.fr")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")