const regex = /"*(\d+)"*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"*(\\d+)"*', 'gm')
const str = `111
222
333
444 555
"111", 222
777
""111
111"""
"ab111"`;
const subst = `"\1"`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);