$re = '/"*(\d+)"*/m';
$str = '111
222
333
444 555
"111", 222
777
""111
111"""
"ab111"';
$subst = "\"\1\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;