import re
regex = re.compile(r"\"*(\d+)\"*", flags=re.MULTILINE)
test_str = ("111 \n"
"222 \n"
" 333 \n"
"444 555 \n"
"\"111\", 222 \n"
"777 \n"
"\"\"111\n"
"111\"\"\"\n"
"\"ab111\"")
subst = "\"\\1\""
result = regex.sub(subst, test_str)
if result:
print(result)