// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)"*(\d+)"*"#).unwrap();
let string = "111
222
333
444 555
\"111\", 222
777
\"\"111
111\"\"\"
\"ab111\"";
let substitution = "\"\\1\"";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}