use strict;
my $str = '111
222
333
444 555
"111", 222
777
""111
111"""
"ab111"';
my $regex = qr/"*(\d+)"*/mp;
my $subst = '"\\1"';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";